Spreedly logo
  • Operational
  • Degraded Performance
  • Partial Outage
  • Major Outage
  • Maintenance
Error causing payment method deliver request failures
Incident Report for Spreedly
Postmortem

Spreedly had detected an issue with Payment Method Deliver requests which were returning an empty response and a response code of 422.

What Happened

On March 26th, 2020 at 8:29am EDT, Spreedly Engineers pushed out a change related to a security update. As a part of this change, an incorrect configuration was used. This caused any Payment Method Deliver request to return a 422 response code with an empty body. Spreedly’s internal monitors detected the issue at 8:30am EDT and Spreedly Engineers reverted the change at 8:33am EDT.

Next Steps

While internal monitors caught the issue shortly after, Spreedly will update internal processes around configuration variables.

Posted Apr 07, 2020 - 09:38 EDT

Resolved
At 12:29PM UTC, Spreedly deployed a change to receiver functionality. This change introduced an error which caused all `deliver` transactions to fail with a 422 response code and an empty response body.

Spreedly reverted the change at 12:33PM UTC and confirmed that the errors ceased.

We apologize for any disruption this incident may have caused and are taking steps to ensure that our systems continue to be resilient for our customers.
Posted Mar 26, 2020 - 08:30 EDT