Dashboard
Incident Report for Spreedly
Postmortem

During an internal database migration of a secondary system, an existing database view was ‘dropped’ before its replacement view was available. The replacement view requires 8+ hours to fully populate with historical data going back more than 4 years. Without the view available for database queries, the dashboard component of the administrative console (which relies in part on this database and view structure) errored and was unable to serve customer requests.

An interim fix was to create a small replacement view with historical data going back only 3 weeks. This was performed to bring the dashboard application online. The final resolution came once a replacement view was fully populated and made available.

This outage did not involve or impact transaction processing.

Posted Apr 23, 2021 - 09:55 EDT

Resolved
Dashboard results are now reporting in real time.

We apologize for any inconvenience this may have caused.
Posted Apr 20, 2021 - 10:58 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 19, 2021 - 20:15 EDT
Update
We have restored access to the Spreedly Insights Dashboard. Historical data has temporarily been limited to the past 3 weeks. We are working on restoring further historical data.
Posted Apr 19, 2021 - 15:05 EDT
Identified
The cause of the Dashboard outage has been identified and a fix is being implemented.
Posted Apr 19, 2021 - 13:04 EDT
Investigating
We are currently experiencing degraded performance on the Spreedly Insights Dashboard. The Dashboard may be unavailable for some users.

We will provide updates as they become available.
Posted Apr 19, 2021 - 12:46 EDT
This incident affected: Supporting Services (Dashboard).