Spreedly logo
  • Operational
  • Degraded Performance
  • Partial Outage
  • Major Outage
  • Maintenance
Spreedly API Errors
Incident Report for Spreedly
Postmortem

September 30, 2021 — Intermittent 500 error responses from Core API Service

On September 30th, in a 20-minute period between 15:24 and 15:44 UTC, a rolling restart caused 6,299 5XX errors served to 25 customers. The rolling restart was self-healing and did not require developer intervention.

What Happened

In an effort to problem-solve an unrelated concern, a service in the Spreedly Production Environment was restarted. The rolling restart cause intermittent 5XX errors to be returned as the Core API Service attempted to authenticate transactions against the restarting servers.

Next Steps

Spreedly will investigate and implement strategies for better application resiliency during temporary service outages.

Posted Oct 07, 2021 - 10:21 EDT

Resolved
A restart of the Spreedly Id service resulted in intermittent 500 errors on Spreedly's Core API.

This impacted a small percentage of transactions and requests to Spreedly's API.

After deploying a fix, all systems appear to be stabilized and functioning. The incident is being considered resolved.

We apologize for any inconvenience and disruption to service.
Posted Sep 30, 2021 - 12:33 EDT
This incident affected: Core Transactional API.