Spreedly logo
  • Operational
  • Degraded Performance
  • Partial Outage
  • Major Outage
  • Maintenance
404 Errors on iFrame/Expresss
Incident Report for Spreedly
Postmortem

After a scheduled change to Spreedly’s infrastructure, Spreedly Engineers detected an issue that causes requests for iFrame/Express to return a 404 error.

What Happened

On March 26th, 2020 at 12:18pm EDT, Spreedly Engineers deployed a change regarding a scheduled infrastructure change. At 12:29pm, an elevated rate of 404 errors were detected as a result of internal monitoring by Spreedly Engineers. By 12:35pm, it was identified that there was an error on in one of the configuration changes that went out and was remedied by 12:40pm.

Next Steps

Spreedly identified an additional automated monitor to be put in place and has done so since this incident occurred. Also, Spreedly will evaluate and implement other checks to detect errors in configuration changes before they are deployed.

Posted Apr 07, 2020 - 09:39 EDT

Resolved
We have seen no further instances of 404 errors. This issue is being marked as resolved.

We apologize for any disruption this incident may have caused and are taking steps to ensure that our systems continue to be resilient for our customers. We will post more details as they become available.
Posted Mar 26, 2020 - 14:35 EDT
Monitoring
At 16:18PM UTC, Spreedly deployed a configuration change to asset caching. We became aware of 404 errors being returned to many applications using Spreedly iFrame and/or Express.

The change was reverted at 16:40PM UTC.

All systems appear to be functional, but we will continue to monitor.

We apologize for the disruption in service.
Posted Mar 26, 2020 - 13:00 EDT
This incident affected: Core Transactional API.