Spreedly logo
  • Operational
  • Degraded Performance
  • Partial Outage
  • Major Outage
  • Maintenance
Account Updater Results
Incident Report for Spreedly
Resolved
We are happy to report that as of this morning, our July 15th Account Updater cycle successfully completed and all customer responses have been sent.

We will continue to work with our provider to monitor and optimize future cycles.
Posted Jul 27, 2022 - 12:57 EDT
Update
We are happy to report that our July 15th Account Updater cycle has been progressing successfully and we anticipate it completing by this Wednesday, July 27th, and in time for our next run to begin as scheduled. We will continue to monitor this run until completion and will provide a status update then.
Posted Jul 25, 2022 - 12:19 EDT
Update
As of today we’ve had a partially successful run of the July 1st Account Updater service, with approximately 30% of the run completed and those updates returned to customers.

We identified a slow down in responses over the last two days caused by our service provider not receiving expected updates from the credit card networks, which has created a significant delay in results being returned. Since we do not estimate receiving those pending results prior to starting our July 15th run, we’ve worked with our Account Updater provider to force cancel any batches that are stuck in processing.

As a result, users who did not receive complete responses as expected from the July 1st cycle of Account Updater will not receive any additional updates for that run. Any cards that were not updated will be sent in the July 15th run.

It is our top priority to ensure our Account Updater future cycles run seamlessly for our customers. Therefore, Spreedly and our provider have taken steps to adjust our Account Updater application to reduce the batch volume and throughput to our provider. These changes have been implemented in order to provide the highest chance of success for the July 15th Account Updater cycle. We will continue to work on longer term solutions jointly with our partner to ensure further optimization for this service going forward.

We will monitor the July 15th run closely with our provider and update as it progresses.
Posted Jul 14, 2022 - 17:01 EDT
Update
We continue monitoring the ongoing July 1st Account Updater run jointly with our provider. We expect to receive the pending responses soon and will notify of any updates.
Posted Jul 13, 2022 - 18:06 EDT
Update
Our July 1st Account Updater run is still progressing and we expect to receive the pending responses soon. We continue to monitor closely with our provider and will update if anything changes.
Posted Jul 12, 2022 - 19:23 EDT
Update
We are closely monitoring the July 1st Account Updater cycle along with our provider and we have been receiving responses, as expected. We will continue to monitor progress and will update if there are any significant changes.
Posted Jul 11, 2022 - 11:50 EDT
Update
We are continuing to monitor the July 1st Account Updater cycle along with our provider. Everything is progressing as expected and we anticipate receiving responses starting tonight or early tomorrow. We will continue to monitor progress and will provide an update on Monday, unless there is a significant change.
Posted Jul 08, 2022 - 15:30 EDT
Update
We are continuing to monitor the July 1st Account Updater cycle along with our provider. We are expecting our first batch of Account Updater responses to arrive tomorrow. We will continue to monitor progress and provide updates daily.
Posted Jul 07, 2022 - 15:40 EDT
Update
In continuing to work closely with our Account Updater partner, we've identified a 50% reduction in processing throughput which is resulting in delays sending cards to the networks for updates. This in turn will add additional time to the end to end account updater cycle processing time. As such, customers should expect additional delays in the receipt of your Account Updater updates.

Both Spreedly and our partner have dedicated engineering resources working on making improvements to throughput and processing efficiency and are also working with the networks to track and monitor the progress of card processing. We will continue daily status updates and will keep you apprised of additional changes if and when they arise.
Posted Jul 06, 2022 - 16:07 EDT
Update
We continue to work with our Account Updater service provider to monitor the July 1st run. At present, the process continues to proceed as expected. We will continue to closely monitor the July 1st run along with our Account Updater vendor, and we will provide daily updates until the process is complete.
Posted Jul 05, 2022 - 16:02 EDT
Update
We have kicked off our July 1st Account Updater cycle and it is progressing as expected so far. We will continue to closely monitor progress with our Account Updater provider daily. Unless there is a significant update to share over the holiday weekend, we will provide our next status page update on Tuesday, July 5th.
Posted Jul 01, 2022 - 17:38 EDT
Monitoring
We’ve worked with our Account Updater provider to identify the root cause and determined this incident to be related to the volume of updates being sent to the Account Updater service, which resulted in significant batch processing delays and records being dropped.

In order to move forward with the July 1st Account Updater cycle in a timely and reliable way, we are proceeding with a cancellation of any June 15 pending batches that are stuck in processing. This means that users who did not receive complete results as expected from the June 15th cycle will not receive further updates until the July 1st cycle.

Spreedly is taking short term steps to adjust our Account Updater application to reduce the batch volume and throughput to our provider so that our service remains resilient and successfully processes subsequent cycles. However, these adjustments will result in longer processing times as we continue to work on longer term solutions with our partner for improved speed and efficiency of the service.

We will continue to closely monitor the status of the July 1 cycle along with our Account Updater service provider and provide daily updates until we can assure its success.
Posted Jun 30, 2022 - 17:31 EDT
Update
Spreedly has determined a path forward working with our Account Updater (AU) service provider.

A formal customer communication is being developed with details on how Spreedly will be addressing the June 15 AU issue, and this will be shared with customers using Spreedly's Account Updater service as soon as possible.
Posted Jun 30, 2022 - 12:36 EDT
Update
Spreedly continues to actively work with our Account Updater (AU) vendor to troubleshoot the issue being seen with a subset of Spreedly customers not receiving their June 15 account updates. We have identified the root cause of the issue with our AU vendor, and we are discussing several options for resolution.

We are continuing to work with our AU vendor to resolve the issue and will provide additional updates later today.
Posted Jun 30, 2022 - 09:53 EDT
Identified
We have identified an issue with our upstream Account Updater provider, and we are working with them to resolve the issue.

We will provide the next update no later than 10AM ET tomorrow or earlier if additional, significant progress is made prior to this time.
Posted Jun 29, 2022 - 16:54 EDT
Update
We are continuing to investigate this issue.
Posted Jun 29, 2022 - 14:22 EDT
Investigating
Spreedly is aware that some customers using the Account Updater service have reported results lower than historical trends. We are actively investigating this issue.
Posted Jun 29, 2022 - 13:17 EDT
This incident affected: Core Secondary API.