Spreedly logo
  • Operational
  • Degraded Performance
  • Partial Outage
  • Major Outage
  • Maintenance
Gateway Integration Errors on Authorize.net
Incident Report for Spreedly
Postmortem

May 25, 2022 — Elevated errors on Authorize.net Verify calls

Authorize.net is one of the many payment service providers that Spreedly provides an integration for their customers.

What Happened

On May 24th, 2022 at 19:50 UTC, Spreedly deployed an update to its integration with Authorize.net. After this deploy, which moved to use $0 amounts for Verify calls on Authorize.net, there was an increase in failures of those calls for payment methods that have missing or invalid fields which were accepted for the prior $1 default. Once this was identified, the change was reverted on May 25th, 2022 at 18:43 UTC and, in doing so, the observed errors subsided.

Next Steps

Spreedly will incorporate tests to check for these use cases along with additional use cases that will help prevent future issues when updating Spreedly’s integrations. In addition, Spreedly will continue to work with gateways to ensure its integrations are up to date.

Posted Jun 03, 2022 - 16:02 EDT

Resolved
This incident has been resolved.
Posted May 25, 2022 - 16:24 EDT
Monitoring
A fix has been deployed and we are monitoring the results.
Posted May 25, 2022 - 15:51 EDT
Identified
A recent update to our Authorize.net Gateway Integration has caused some elevated error rates for Verify transactions. A fix has been identified and is being implemented.
Posted May 25, 2022 - 15:00 EDT
This incident affected: Gateway Integrations (Gateways).