After closely monitoring and confirming that all systems are stabilized and functioning as expected, this incident is considered resolved. No further customer impact is expected.
We are completing our investigation concerning the causes of the incident and any residual impact.
We apologize for any inconvenience or disruption.
Posted Jan 27, 2026 - 14:29 EST
Monitoring
We’ve implemented a fix and stabilized the 3DS2 Global transactions. Our team is monitoring the situation closely to ensure there are no additional impacts.
Please continue to follow our StatusPage for the latest update.
Posted Jan 27, 2026 - 14:25 EST
Investigating
Spreedly has detected an issue potentially resulting in a high number of pending 3DS2 Global transactions. While we are providing an early notification in an effort to alert you as quickly as possible, we are still investigating the actual scope and impact and will provide an update as soon as more details are available.