Spreedly logo
  • Operational
  • Degraded Performance
  • Partial Outage
  • Major Outage
  • Maintenance
Connection Timeouts to our Core Transactional API
Incident Report for Spreedly
Resolved
After continued investigation and monitoring, this appears to be a transient issue between the AWS us-east-1 region and our datacenter. We will continue to monitor and will mark this incident as resolved.
Posted Aug 03, 2018 - 15:20 EDT
Update
We are continuing to investigate these connection timeouts. All identified timeout issues so far have been on connections between AWS us-east-1 and our datacenter. We are continuing to run tests to isolate it further.
Posted Aug 03, 2018 - 13:47 EDT
Update
We are continuing to investigate this issue. We've identified the connection timeouts are happening on connection to the Core Transactional API and do not start or leave transactions in an unknown state. These calls are safe to retry and we will continue to provide updates as we isolate the issue further.
Posted Aug 03, 2018 - 12:05 EDT
Investigating
We are investigating connection timeouts to our Core API. A small number of customers have experienced connection timeouts as a percentage of their transactions and a team is working to investigate the issue. Please feel free to reach out to us with any questions or concerns at success@spreedly.com
Posted Aug 03, 2018 - 11:27 EDT
This incident affected: Core Transactional API.