Spreedly logo
  • Operational
  • Degraded Performance
  • Partial Outage
  • Major Outage
  • Maintenance
3DS2 Errors with some Mastercard transactions
Incident Report for Spreedly
Resolved
We have received confirmation from Mastercard that a service disruption, which was identified for their Smart Interface and caused customers to experience intermittent transaction failures during the impact period, has now been restored.

We appreciate your patience while we tracked this issue with our partners.
Posted Jun 12, 2023 - 18:14 EDT
Update
Our team is still tracking an issue that started June 12th, 2023, at 07:03 am EST (12:03 UTC).

Customers may continue to experience transaction failures within our 3DS2 Global Solution. Our Global 3DS2 provider and Mastercard have both confirmed this is an ongoing issue impacting Mastercard's card types. We understand that the Mastercard team is working to mitigate the issue and restore service to all customers as soon as possible.

We will provide an update as soon as more details are available.

Thank you for your patience at this time.
Posted Jun 12, 2023 - 15:24 EDT
Identified
We have identified an issue which is impacting some Mastercard 3DS2 transactions for a subset of our customers using our 3DS2 Global solution. These transactions are failing with the following error "Remote Error: Intermediate layer error - error in intermediate layer (message received invalid. could not read the message. authentication response)". We have logged a ticket with our third party 3DS2 provider and they are actively investigating. We will provide updates as these become available to us.
Posted Jun 12, 2023 - 11:04 EDT
This incident affected: Core Transactional API.