Spreedly logo
  • Operational
  • Degraded Performance
  • Partial Outage
  • Major Outage
  • Maintenance
Global Collect Gateway 404 Errors
Incident Report for Spreedly
Postmortem

December 11th, 2024 — Global Collect Gateway Transaction Failures

A change to the Global Collect gateway integration resulted in transaction failures for a subset of customers.

What Happened

At 20:50 UTC, an update was made to the Global Collect gateway integration. Initial monitoring and observability did not surface issues. At 23:53 UTC, Spreedly Engineering began researching an elevated number of transaction failures on the Global Collect gateway. After investigation, it was determined that the prior update to the Global Collect gateway was causing the increase in transaction failures. At 01:02 UTC on December 12th, 2024, the change was reverted and service to the Global Collect gateway was restored.

Next Steps

Spreedly Engineering is reviewing and improving internal observability to better surface gateway-specific transaction failure rate anomalies.

Posted Dec 16, 2024 - 14:11 EST

Resolved
We have identified an issue with a code change that was deployed around 3:35 pm EST that affected the Global Collect gateway. We have rolled back this code change and are now seeing successful transactions.

After a period of monitoring, we have not seen any recurrence of this issue. The incident is being considered resolved. We will publish a postmortem on our status page as soon as possible.

We apologize for any inconvenience this has caused.
Posted Dec 11, 2024 - 21:05 EST
Investigating
Spreedly is investigating an issue that could potentially impact our services, leading to 404 errors on the Global Collect gateway.

We are taking all necessary measures to investigate the matter and determine the extent of the situation. We will provide an update as soon as more details are available.

Thank you for your patience.
Posted Dec 11, 2024 - 19:42 EST
This incident affected: Core Transactional API.