Spreedly logo

Dodgeball Checkpoint Latency

Incident Report for Spreedly

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 12:09 EDT

Update

After closely monitoring and confirming that all systems are stabilized and functioning as expected, this incident is considered resolved. No further customer impact is expected.

We apologize for any inconvenience or disruption.
Posted Mar 19, 2026 - 12:07 EDT

Monitoring

We’ve implemented a fix and stabilized the Dodgeball component that was experiencing a partial outage. We are continuing to monitor
Posted Mar 19, 2026 - 11:55 EDT

Update

We are working to resolve an issue with delayed processing of requests to the Dodgeball services.
Posted Mar 19, 2026 - 11:30 EDT

Identified

We are currently investigating performance of the Dodgeball service.
Posted Mar 19, 2026 - 11:13 EDT
This incident affected: Dodgeball.