Spreedly logo

Elevated 3DS Failures

Incident Report for Spreedly

Resolved

At 1:08 PM, 3DS provider, Seglan, deployed changes to address the issue. After a period of monitoring, we’ve observed normal performance and are declaring this incident resolved.
Posted Sep 19, 2025 - 13:46 EDT

Investigating

We are currently investigating elevated 3DS failures with our Global 3DS provider, Seglan.
Posted Sep 19, 2025 - 11:53 EDT
This incident affected: 3DS Global.