Our team has completed the backfill process, and all missing transaction data has now been fully restored in Spreedly reporting. Transaction reporting is up to date and functioning as expected.
All primary processing systems continued to operate normally throughout this incident, and no transaction processing impact occurred.
Posted Dec 10, 2025 - 15:04 EST
Monitoring
We have identified and fixed the issue that was causing some transaction data to be missing from Spreedly reporting. Our team is now working on backfilling the missing reporting data to ensure completeness and accuracy.
All primary processing systems continue to operate normally, and there is no impact to transaction processing.
Posted Dec 10, 2025 - 09:42 EST
Update
Our team continues to investigate the root cause of the missing transaction data appearing in Spreedly reporting. All primary datastores and transactional processing are functioning normally, and there is no indication of data loss at the source. The issue appears to be isolated to the reporting ingestion process.
Posted Dec 10, 2025 - 01:53 EST
Investigating
We are investigating an issue where roughly 30–40% of transactions are not appearing in Spreedly reporting since 12/03. Primary datastores and secondary services show no data loss, indicating the issue lies within the reporting ingestion process.