Spreedly logo

Delayed Processing of Some 3DS Global Transactions

Incident Report for Spreedly

Postmortem

December 18, 2025 — Delayed Processing of Some 3DS Global Transactions

A targeted update intended for Gateway-Specific 3DS processing impacted a subset of 3DS Global transactions. This caused a small number of transactions to remain in a "Pending" state rather than progressing to completion.

What Happened

Between 08:59 PM and 09:03 PM UTC on December 16, 2025, a deployment intended to update Gateway-Specific 3DS logic inadvertently affected the processing of 3DS Global transactions. As a result, 52 transactions failed to reach a final state and remained "pending." During this 4-minute window, customers attempting a 3DS-authenticated operation would have encountered an interruption, preventing their transactions from completing. Our team identified the impact immediately and rolled back the change to restore normal service.

Next Steps

We have successfully identified and corrected the underlying logic error within the change. We are also enhancing our automated deployment tests to better catch cross-module dependencies of this nature. We sincerely apologize for any disruption this caused to your operations.

— The Spreedly Team

Posted Dec 18, 2025 - 16:46 EST

Resolved

Between 3:59 and 4:03 EST, customers may have experienced degraded performance when processing transactions that required 3D Secure (3DS) authentication via our Global 3DS service.
Performance has since returned to normal, and no further impact has been observed.
If you have any questions about potential impact to your transactions during this time window, please reach out to Spreedly Support for assistance.
Posted Dec 16, 2025 - 16:56 EST