Spreedly logo

Intermittent 500 Errors on List and Show Endpoints

Incident Report for Spreedly

Resolved

We identified and resolved the issue causing intermittent 500 responses on certain list and retrieval endpoints. A configuration update has been deployed to prevent requests from being prematurely terminated, and we are continuing to monitor the service.
Posted Jul 11, 2026 - 11:38 EDT

Investigating

We are investigating elevated error rates affecting certain API requests. Some list and retrieval endpoints may return intermittent 500 responses while we work to identify the root cause.
Posted Jul 11, 2026 - 10:33 EDT
This incident affected: Core Transactional API.