Spreedly logo

Degraded performance on Cybersource Credit transactions

Incident Report for Spreedly

Resolved

After closely monitoring and confirming that all systems are stabilized and functioning as expected, this incident is considered resolved. No further customer impact is expected.

We are completing our investigation concerning the causes of the incident and any residual impact.

We apologize for any inconvenience or disruption.
Posted Jul 08, 2026 - 12:54 EDT

Identified

We have identified transient internal DNS resolution error that occurred between 15:00 and 15:05 UTC causing select 500 errors across Spreedly services. We continue to investigate the full impact and will provide additional information as it becomes available.
Posted Jul 08, 2026 - 12:08 EDT

Investigating

Spreedly has detected an issue potentially resulting in degraded performance on Cybersource Credit transactions. While we are providing this early notification in an effort to alert you as quickly as possible, we are still investigating the actual scope and impact. We will provide an update as soon as more details are available.
Posted Jul 08, 2026 - 11:22 EDT
This incident affected: Core Transactional API.