Spreedly logo
  • Operational
  • Degraded Performance
  • Partial Outage
  • Major Outage
  • Maintenance
Core Transactional API Errors
Incident Report for Spreedly
Postmortem

December 12th, 2024 — Payment Method Tokenization Errors

Server maintenance to reduce log volume caused an internal service to become unavailable, causing payment method tokenization requests to fail.

What Happened

At approximately 17:45 UTC on December 12th, 2024, a logging configuration change made to reduce log volume resulted in an internal service becoming unavailable. Traffic was shifted to an alternate service during the outage window to reduce impact. At approximately 18:01 the internal service resumed normal operation and service was restored.

Payment transactions were negatively impacted during this time.

Next Steps

Spreedly Engineering is investigating the coupling of the configuration change to the internal service and will be taking steps to prevent the issue from occuring in the future.

Posted Dec 17, 2024 - 18:03 EST

Resolved
After closely monitoring and confirming that all systems are stabilized and functioning as expected, this incident is considered resolved. No further customer impact is expected.

We apologize for any inconvenience or disruption.
Posted Dec 12, 2024 - 14:25 EST
Monitoring
From 12:47 to 12:58 PM EST, we encountered an issue that affected customers attempting to tokenize a payment method and transacting with a payment method, resulting in a 500 error. We have identified the problem and implemented a fix.

Our team is closely monitoring the situation to ensure there are no further impacts.

If you need additional assistance, please reach out to our Support team.
Posted Dec 12, 2024 - 13:32 EST
Investigating
Spreedly has discovered an issue that could potentially impact new payment method creation.

We are taking all necessary measures to investigate the matter and determine the extent of the situation. We will provide an update as soon as more details are available.
Posted Dec 12, 2024 - 13:04 EST
This incident affected: Core Transactional API.